AnalyticalLinkIsValidHub Method |
Checks whether input hub is valid for an AnalyticalLink.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidHub(
Document doc,
ElementId hubId
)
Public Shared Function IsValidHub (
doc As Document,
hubId As ElementId
) As Boolean
public:
static bool IsValidHub(
Document^ doc,
ElementId^ hubId
)
static member IsValidHub :
doc : Document *
hubId : ElementId -> bool
Parameters
- doc Document
-
Hubs's document.
- hubId ElementId
-
Hub to test for validity.
Return Value
Boolean
True is returned when provided hubId points hub that is valid for AnalyticalLink, false otherwise.
Exceptions
See Also