The entry point to the native IFC import function. Processes the main IfcProject and creates appropriate Revit elements.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void ProcessIFCProject( IFCAnyHandle ifcProject ) |
Visual Basic |
---|
Public Sub ProcessIFCProject ( _ ifcProject As IFCAnyHandle _ ) |
Visual C++ |
---|
public: void ProcessIFCProject( IFCAnyHandle^ ifcProject ) |
Parameters
- ifcProject
- Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcProject containing the entities in the IFC file.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |