For shape driven rebar returns all possible RebarConstraints that could be used for a specified RebarConstrainedHandle.
For free form rebar will return an empty list.
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public IList<RebarConstraint> GetConstraintCandidatesForHandle( RebarConstrainedHandle handle ) |
Visual Basic |
---|
Public Function GetConstraintCandidatesForHandle ( _ handle As RebarConstrainedHandle _ ) As IList(Of RebarConstraint) |
Visual C++ |
---|
public: IList<RebarConstraint^>^ GetConstraintCandidatesForHandle( RebarConstrainedHandle^ handle ) |
Parameters
- handle
- Type: Autodesk.Revit.DB.Structure..::..RebarConstrainedHandle
The RebarConstrainedHandle for which constraint candidates are sought.
Return Value
A collection of RebarConstraints
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The RebarConstraintsManager does not manage a valid Rebar element. |