RebarConstraintsManagerGetConstraintCandidatesForHandle(RebarConstrainedHandle) Method |
Note: This API is now obsolete.
For shape driven rebar returns all possible automatic RebarConstraints that could be used for a specified RebarConstrainedHandle.
For free form rebar will return an empty list.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax[ObsoleteAttribute("This property is deprecated in Revit 2025 and may be removed in a later version of Revit. Please use RebarConstraintsManager.GetConstraintCandidatesForHandle(Autodesk.Revit.DB.Structure.RebarConstrainedHandle, Autodesk.Revit.DB.ElementId) or RebarConstraintsManager.GetConstraintCandidatesForHandle(Autodesk.Revit.DB.Structure.RebarConstrainedHandle, Autodesk.Revit.DB.Reference) instead. If you want to get the direct neighbors of a rebar host you can use Autodesk.Revit.DB.Structure.RebarHostData.GetRebarHostDirectNeighbors(Autodesk.Revit.DB.Element hostElement). If you want to get all the rebars in a host you can use Autodesk.Revit.DB.Structure.RebarHostData.GetRebarsInHost().")]
public IList<RebarConstraint> GetConstraintCandidatesForHandle(
RebarConstrainedHandle handle
)
<ObsoleteAttribute("This property is deprecated in Revit 2025 and may be removed in a later version of Revit. Please use RebarConstraintsManager.GetConstraintCandidatesForHandle(Autodesk.Revit.DB.Structure.RebarConstrainedHandle, Autodesk.Revit.DB.ElementId) or RebarConstraintsManager.GetConstraintCandidatesForHandle(Autodesk.Revit.DB.Structure.RebarConstrainedHandle, Autodesk.Revit.DB.Reference) instead. If you want to get the direct neighbors of a rebar host you can use Autodesk.Revit.DB.Structure.RebarHostData.GetRebarHostDirectNeighbors(Autodesk.Revit.DB.Element hostElement). If you want to get all the rebars in a host you can use Autodesk.Revit.DB.Structure.RebarHostData.GetRebarsInHost().")>
Public Function GetConstraintCandidatesForHandle (
handle As RebarConstrainedHandle
) As IList(Of RebarConstraint)
public:
[ObsoleteAttribute(L"This property is deprecated in Revit 2025 and may be removed in a later version of Revit. Please use RebarConstraintsManager.GetConstraintCandidatesForHandle(Autodesk.Revit.DB.Structure.RebarConstrainedHandle, Autodesk.Revit.DB.ElementId) or RebarConstraintsManager.GetConstraintCandidatesForHandle(Autodesk.Revit.DB.Structure.RebarConstrainedHandle, Autodesk.Revit.DB.Reference) instead. If you want to get the direct neighbors of a rebar host you can use Autodesk.Revit.DB.Structure.RebarHostData.GetRebarHostDirectNeighbors(Autodesk.Revit.DB.Element hostElement). If you want to get all the rebars in a host you can use Autodesk.Revit.DB.Structure.RebarHostData.GetRebarsInHost().")]
IList<RebarConstraint^>^ GetConstraintCandidatesForHandle(
RebarConstrainedHandle^ handle
)
[<ObsoleteAttribute("This property is deprecated in Revit 2025 and may be removed in a later version of Revit. Please use RebarConstraintsManager.GetConstraintCandidatesForHandle(Autodesk.Revit.DB.Structure.RebarConstrainedHandle, Autodesk.Revit.DB.ElementId) or RebarConstraintsManager.GetConstraintCandidatesForHandle(Autodesk.Revit.DB.Structure.RebarConstrainedHandle, Autodesk.Revit.DB.Reference) instead. If you want to get the direct neighbors of a rebar host you can use Autodesk.Revit.DB.Structure.RebarHostData.GetRebarHostDirectNeighbors(Autodesk.Revit.DB.Element hostElement). If you want to get all the rebars in a host you can use Autodesk.Revit.DB.Structure.RebarHostData.GetRebarsInHost().")>]
member GetConstraintCandidatesForHandle :
handle : RebarConstrainedHandle -> IList<RebarConstraint>
Parameters
- handle RebarConstrainedHandle
-
The RebarConstrainedHandle for which constraint candidates are sought.
Return Value
IListRebarConstraint
A collection of RebarConstraints
Exceptions
RemarksWhen a bar is placed or moved is searching for new constraints in and automatic way, which are the ones returned by this function.
This list contains possible constraints to host's faces and cover and to the first level host neighbors' faces and cover.
If this is a Rebar of Standard style the list will contain possible constraints to Stirrup bars (corners or segments).
If you want to get all possible constraints to host or to another rebar (no matter what style it is) you should use
RebarConstraintsManager.GetConstraintCandidatesForHandle(Autodesk.Revit.DB.Structure.RebarConstrainedHandle, Autodesk.Revit.DB.ElementId) or
RebarConstraintsManager.GetConstraintCandidatesForHandle(Autodesk.Revit.DB.Structure.RebarConstrainedHandle, Autodesk.Revit.DB.Reference).
See Also