Checks whether the input height is valid for a non-continuous rail in its associated railing type.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019
Syntax
C# |
---|
public bool IsValidNonContinuousRailHeight( double height ) |
Visual Basic |
---|
Public Function IsValidNonContinuousRailHeight ( _ height As Double _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidNonContinuousRailHeight( double height ) |
Parameters
- height
- Type: System..::..Double
The height to be checked.
Return Value
True if the height is smaller than the height of [!:Autodesk::Revit::DB::Architecture::RailingType], false otherwise.
Remarks
The height cannot be greater than the height of a [!:Autodesk::Revit::DB::Architecture::RailingType]
to which the non-continuous rail belongs.