NonContinuousRailInfoIsValidNonContinuousRailHeight Method

Checks whether the input height is valid for a non-continuous rail in its associated railing type.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidNonContinuousRailHeight(
	double height
)

Parameters

height  Double
The height to be checked.

Return Value

Boolean
True if the height is smaller than the height of [!:Autodesk::Revit::DB::Architecture::RailingType], false otherwise.
Remarks
The height cannot be greater than the height of a [!:Autodesk::Revit::DB::Architecture::RailingType] to which the non-continuous rail belongs.
See Also