Retrieves or changes approval type of the Structural Connection Handler.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public ElementId ApprovalTypeId { get; set; } |
Visual Basic |
---|
Public Property ApprovalTypeId As ElementId Get Set |
Visual C++ |
---|
public: property ElementId^ ApprovalTypeId { ElementId^ get (); void set (ElementId^ value); } |
Field Value
Name of connection.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |