Sets the handles representing the cardinal directions in 2D.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static void SetGlobal2DDirectionHandles( bool positive, IFCAnyHandle xDir, IFCAnyHandle yDir ) |
Visual Basic |
---|
Public Shared Sub SetGlobal2DDirectionHandles ( _ positive As Boolean, _ xDir As IFCAnyHandle, _ yDir As IFCAnyHandle _ ) |
Visual C++ |
---|
public: static void SetGlobal2DDirectionHandles( bool positive, IFCAnyHandle^ xDir, IFCAnyHandle^ yDir ) |
Parameters
- positive
- Type: System..::..Boolean
True if the handles returned should be in the positive direction, false if the handles should be in the negative direction.
- xDir
- Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The X direction handle.
- yDir
- Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The Y direction handle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |