Shows the elements by zoom to fit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public void ShowElements(
	ICollection<ElementId> elementIds
)
Visual Basic
Public Sub ShowElements ( _
	elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
void ShowElements(
	ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of element ids which will be shown.

Remarks

Places all the elements on the screen by moving the view.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullExceptionelementIds is null.
Autodesk.Revit.Exceptions..::..ArgumentExceptionMember of elementIds is null.
Autodesk.Revit.Exceptions..::..ArgumentExceptionMember of elementIds is not valid.

See Also