Starts the edit scope.
Namespace: Autodesk.Revit.DB.VisualAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018.1
Syntax
C# |
---|
public Asset Start( ElementId assetElementId ) |
Visual Basic |
---|
Public Function Start ( _ assetElementId As ElementId _ ) As Asset |
Visual C++ |
---|
public: Asset^ Start( ElementId^ assetElementId ) |
Parameters
- assetElementId
- Type: Autodesk.Revit.DB..::..ElementId
The appearance asset element whose asset should be edited.
Return Value
The appearance asset to be used for editing.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |