Insert a new AssetPropertyDouble4 containing the input value to this list.
Namespace: Autodesk.Revit.DB.VisualAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018.1
Syntax
C# |
---|
public void InsertNewAssetAsColor( Color value, int index ) |
Visual Basic |
---|
Public Sub InsertNewAssetAsColor ( _ value As Color, _ index As Integer _ ) |
Visual C++ |
---|
public: void InsertNewAssetAsColor( Color^ value, int index ) |
Parameters
- value
- Type: Autodesk.Revit.DB..::..Color
The color value to insert.
- index
- Type: System..::..Int32
An integer index.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | index is out of range. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The asset property is not editable. |