Checks that the building construction class falls within an appropriate range.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static bool CheckBuildingConstructionClass( HVACLoadConstructionClass buildingConstructionClass ) |
Visual Basic |
---|
Public Shared Function CheckBuildingConstructionClass ( _ buildingConstructionClass As HVACLoadConstructionClass _ ) As Boolean |
Visual C++ |
---|
public: static bool CheckBuildingConstructionClass( HVACLoadConstructionClass buildingConstructionClass ) |
Parameters
- buildingConstructionClass
- Type: Autodesk.Revit.DB.Analysis..::..HVACLoadConstructionClass
The building construction class to be checked.
Return Value
True if the building construction class falls within an appropriate range, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |