Gets the openings data from the element.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static IList<IFCOpeningData> GetOpeningData( ExporterIFC exporterIFC, Element element, Transform lcs, IFCRange range ) |
Visual Basic |
---|
Public Shared Function GetOpeningData ( _ exporterIFC As ExporterIFC, _ element As Element, _ lcs As Transform, _ range As IFCRange _ ) As IList(Of IFCOpeningData) |
Visual C++ |
---|
public: static IList<IFCOpeningData^>^ GetOpeningData( ExporterIFC^ exporterIFC, Element^ element, Transform^ lcs, IFCRange^ range ) |
Parameters
- exporterIFC
- Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
- element
- Type: Autodesk.Revit.DB..::..Element
The element.
- lcs
- Type: Autodesk.Revit.DB..::..Transform
The local coordinate system for the extrusion.
- range
- Type: Autodesk.Revit.DB.IFC..::..IFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire element is used.
Return Value
The opening data.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |