The Windows Presentation Framework object containing the pane's user interface.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public FrameworkElement FrameworkElement { get; set; } |
Visual Basic |
---|
Public Property FrameworkElement As FrameworkElement Get Set |
Visual C++ |
---|
public: property FrameworkElement^ FrameworkElement { FrameworkElement^ get (); void set (FrameworkElement^ value); } |
Remarks
Using a System.Windows.Controls.Page is recommended. This can be null, in which case
it is assumed an IFrameworkElementCreator is provided to create the element on demand.