Returns the Id of the currently active application-level server of the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public Guid GetActiveServerId()
Visual Basic
Public Function GetActiveServerId As Guid
Visual C++
public:
Guid GetActiveServerId()

Return Value

The GUID of the active server, or an invalid GUID if there is no active server assigned.

See Also