Adds an IfcElement handle to associate with the IfcProduct in this wrapper.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void AddElement( IFCAnyHandle elementHandle, IFCLevelInfo pLevelInfo, IFCExtrusionCreationData params, bool relateToLevel ) |
Visual Basic |
---|
Public Sub AddElement ( _ elementHandle As IFCAnyHandle, _ pLevelInfo As IFCLevelInfo, _ params As IFCExtrusionCreationData, _ relateToLevel As Boolean _ ) |
Visual C++ |
---|
public: void AddElement( IFCAnyHandle^ elementHandle, IFCLevelInfo^ pLevelInfo, IFCExtrusionCreationData^ params, bool relateToLevel ) |
Parameters
- elementHandle
- Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcElement handle.
- pLevelInfo
- Type: Autodesk.Revit.DB.IFC..::..IFCLevelInfo
The level info.
- params
- Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
The extrusion creation data associated with the given element. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic).
- relateToLevel
- Type: System..::..Boolean
True to relate the element to the level, false otherwise.
Remarks
If the IFCLevelInfo is not provided, and relateToLevel to true, the handle will be associated to the building handle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |