Get a set of FabricationPartSizeMapSet of all straight sizes for all services.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2018.2

Syntax

C#
public ISet<FabricationPartSizeMap> GetMapOfAllSizesForStraights()
Visual Basic
Public Function GetMapOfAllSizesForStraights As ISet(Of FabricationPartSizeMap)
Visual C++
public:
ISet<FabricationPartSizeMap^>^ GetMapOfAllSizesForStraights()

Return Value

Returns the map of sizes for straights or an empty map if there are none.

See Also