Creates a new StructuralConnectionHandlerType object with a default name.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static ElementId CreateDefaultStructuralConnectionHandlerType( Document pADoc ) |
Visual Basic |
---|
Public Shared Function CreateDefaultStructuralConnectionHandlerType ( _ pADoc As Document _ ) As ElementId |
Visual C++ |
---|
public: static ElementId^ CreateDefaultStructuralConnectionHandlerType( Document^ pADoc ) |
Parameters
- pADoc
- Type: Autodesk.Revit.DB..::..Document
The document.
Return Value
The newly created type id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction. |