StructuralConnectionHandlerTypeCreateDefaultStructuralConnectionHandlerType Method

Creates a new StructuralConnectionHandlerType object with a default name.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ElementId CreateDefaultStructuralConnectionHandlerType(
	Document pADoc
)

Parameters

pADoc  Document
The document.

Return Value

ElementId
The newly created type id.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also