Retrieves a box that circumscribes all geometry of the subelement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public BoundingBoxXYZ GetBoundingBox( View dbView ) |
Visual Basic |
---|
Public Function GetBoundingBox ( _ dbView As View _ ) As BoundingBoxXYZ |
Visual C++ |
---|
public: BoundingBoxXYZ^ GetBoundingBox( View^ dbView ) |
Parameters
- dbView
- Type: Autodesk.Revit.DB..::..View
The view for view-specific geometry or nullNothingnullptra null reference (Nothing in Visual Basic) for model geometry.
Return Value
The bounding box.
Remarks
Pass in a view to query view-specific (e.g., cut) geometry or nullNothingnullptra null reference (Nothing in Visual Basic) for model
geometry. If the view box is not known or cannot be calculated, this will return the model box;
if the model box is not known,
this will return nullNothingnullptra null reference (Nothing in Visual Basic). The box will always be aligned to the default axes of the
model coordinate system (thus no rotation should be applied to the return value).
Also note that this bounding box volume
may enclose geometry that is not obvious. For example, the "flip controls" that
could be part of a family will be included in the computation of the bounding box even
though they are not always visible in the family instance of the family.