SubelementGetBoundingBox Method |
Retrieves a box that circumscribes all geometry of the subelement.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic BoundingBoxXYZ GetBoundingBox(
View dbView
)
Public Function GetBoundingBox (
dbView As View
) As BoundingBoxXYZ
public:
BoundingBoxXYZ^ GetBoundingBox(
View^ dbView
)
member GetBoundingBox :
dbView : View -> BoundingBoxXYZ
Parameters
- dbView View
-
The view for view-specific geometry or for model geometry.
Return Value
BoundingBoxXYZ
The bounding box.
Remarks
Pass in a view to query view-specific (e.g., cut) geometry or for model
geometry. If the view box is not known or cannot be calculated, this will return the model box;
if the model box is not known,
this will return . The box will always be aligned to the default axes of the
model coordinate system (thus no rotation should be applied to the return value).
Also note that this bounding box volume
may enclose geometry that is not obvious. For example, the "flip controls" that
could be part of a family will be included in the computation of the bounding box even
though they are not always visible in the family instance of the family.
See Also