Stores the default entity in the data.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void SetDefaultEntity( Entity defaultEntity ) |
Visual Basic |
---|
Public Sub SetDefaultEntity ( _ defaultEntity As Entity _ ) |
Visual C++ |
---|
public: void SetDefaultEntity( Entity^ defaultEntity ) |
Parameters
- defaultEntity
- Type: Autodesk.Revit.DB.ExtensibleStorage..::..Entity
The Entity to be stored.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Writing of Entities of this Schema is not allowed to the current add-in. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |