Get a collection of valid placement types for input family symbol.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public IList<FaceBasedPlacementType> GetPlacementTypes( FamilySymbol familySymbol, View pDBView ) |
Visual Basic |
---|
Public Function GetPlacementTypes ( _ familySymbol As FamilySymbol, _ pDBView As View _ ) As IList(Of FaceBasedPlacementType) |
Visual C++ |
---|
public: IList<FaceBasedPlacementType>^ GetPlacementTypes( FamilySymbol^ familySymbol, View^ pDBView ) |
Parameters
- familySymbol
- Type: Autodesk.Revit.DB..::..FamilySymbol
The family symbol.
- pDBView
- Type: Autodesk.Revit.DB..::..View
The view in which the family instance will be placed in.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |