UIDocumentGetPlacementTypes Method

Get a collection of valid placement types for input family symbol.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<FaceBasedPlacementType> GetPlacementTypes(
	FamilySymbol familySymbol,
	View pDBView
)

Parameters

familySymbol  FamilySymbol
The family symbol.
pDBView  View
The view in which the family instance will be placed in.

Return Value

IListFaceBasedPlacementType
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also