Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static void ExportExtrudedSlabOpenings( ExporterIFC exporterIFC, Element pElem, IFCLevelInfo levelInfo, IFCAnyHandle localPlacementAny, IList<IFCAnyHandle> elementSlabAnyArr, IList<IList<CurveLoop>> extrusionLoops, Plane plane, IFCProductWrapper pWrapper ) |
Visual Basic |
---|
Public Shared Sub ExportExtrudedSlabOpenings ( _ exporterIFC As ExporterIFC, _ pElem As Element, _ levelInfo As IFCLevelInfo, _ localPlacementAny As IFCAnyHandle, _ elementSlabAnyArr As IList(Of IFCAnyHandle), _ extrusionLoops As IList(Of IList(Of CurveLoop)), _ plane As Plane, _ pWrapper As IFCProductWrapper _ ) |
Visual C++ |
---|
public: static void ExportExtrudedSlabOpenings( ExporterIFC^ exporterIFC, Element^ pElem, IFCLevelInfo^ levelInfo, IFCAnyHandle^ localPlacementAny, IList<IFCAnyHandle^>^ elementSlabAnyArr, IList<IList<CurveLoop^>^>^ extrusionLoops, Plane^ plane, IFCProductWrapper^ pWrapper ) |
Parameters
- exporterIFC
- Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
- pElem
- Type: Autodesk.Revit.DB..::..Element
- levelInfo
- Type: Autodesk.Revit.DB.IFC..::..IFCLevelInfo
- localPlacementAny
- Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
- elementSlabAnyArr
- Type: System.Collections.Generic..::..IList<(Of <(<'IFCAnyHandle>)>)>
- extrusionLoops
- Type: System.Collections.Generic..::..IList<(Of <(<'IList<(Of <(<'CurveLoop>)>)>>)>)>
- plane
- Type: Autodesk.Revit.DB..::..Plane
- pWrapper
- Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper