Set the linked connector element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void SetLinkedConnectorElement( ConnectorElement otherConnector ) |
Visual Basic |
---|
Public Sub SetLinkedConnectorElement ( _ otherConnector As ConnectorElement _ ) |
Visual C++ |
---|
public: void SetLinkedConnectorElement( ConnectorElement^ otherConnector ) |
Parameters
- otherConnector
- Type: Autodesk.Revit.DB..::..ConnectorElement
The connector to link to.
Remarks
Set the linked connector to nullNothingnullptra null reference (Nothing in Visual Basic) to remove the link.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The connector being linked to is a different domain than that of the calling connector. -or- The connector being linked to is the same as the calling connector. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This connector type does not support linked connectors. |