Adds member element ids to the mechanical equipment set.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019
Syntax
C# |
---|
public void Add( ISet<ElementId> elemIds ) |
Visual Basic |
---|
Public Sub Add ( _ elemIds As ISet(Of ElementId) _ ) |
Visual C++ |
---|
public: void Add( ISet<ElementId^>^ elemIds ) |
Parameters
- elemIds
- Type: System.Collections.Generic..::..ISet<(Of <(<'ElementId>)>)>
Element ids to be added to the mechanical equipment set.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The valid members must have the same classification and system. They cannot be a member of existing set. -or- These elements are serially connected with each other, or with one of the set members. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |