MechanicalEquipmentSetAdd Method |
Adds member element ids to the mechanical equipment set.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void Add(
ISet<ElementId> elemIds
)
Public Sub Add (
elemIds As ISet(Of ElementId)
)
public:
void Add(
ISet<ElementId^>^ elemIds
)
member Add :
elemIds : ISet<ElementId> -> unit
Parameters
- elemIds ISetElementId
-
Element ids to be added to the mechanical equipment set.
ExceptionsException | Condition |
---|
ArgumentException |
The valid members must have the same classification and system. They cannot be a member of existing set.
-or-
These elements are serially connected with each other, or with one of the set members.
|
ArgumentNullException |
A non-optional argument was null
|
See Also