Returns the face to which the RebarConstraint is attached associated to the given target index.
The RebarConstraintType of the RebarConstraint must be 'FixedDistanceToHostFace' or 'ToCover.'
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2018
Syntax
C# |
---|
public Face GetTargetHostFaceAndTransform(
int targetIndex,
Transform faceTransform
) |
Visual Basic |
---|
Public Function GetTargetHostFaceAndTransform ( _
targetIndex As Integer, _
faceTransform As Transform _
) As Face |
Visual C++ |
---|
public:
Face^ GetTargetHostFaceAndTransform(
int targetIndex,
Transform^ faceTransform
) |
Parameters
- targetIndex
- Type: System..::..Int32
The index of the target. Should be between 0 and NumberOfTargets().
- faceTransform
- Type: Autodesk.Revit.DB..::..Transform
Returns the transform that is associated to the face's element geometry.
Return Value
Requested Face.
Exceptions
See Also