RebarConstraintGetTargetHostFaceAndTransform Method |
Returns the face to which the RebarConstraint is attached associated to the given target index.
The RebarConstraintType of the RebarConstraint must be 'FixedDistanceToHostFace' or 'ToCover'.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Face GetTargetHostFaceAndTransform(
int targetIndex,
Transform faceTransform
)
Public Function GetTargetHostFaceAndTransform (
targetIndex As Integer,
faceTransform As Transform
) As Face
public:
Face^ GetTargetHostFaceAndTransform(
int targetIndex,
Transform^ faceTransform
)
member GetTargetHostFaceAndTransform :
targetIndex : int *
faceTransform : Transform -> Face
Parameters
- targetIndex Int32
-
The index of the target. Should be between 0 and NumberOfTargets().
- faceTransform Transform
-
Returns the transform that is associated to the face's element geometry.
Return Value
Face
Requested Face.
Exceptions
See Also