Checks whether a PathType enum value will be valid to
use with this ExternalFileReference.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public bool IsValidPathTypeForExternalFileReference( PathType pathType ) |
Visual Basic |
---|
Public Function IsValidPathTypeForExternalFileReference ( _ pathType As PathType _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidPathTypeForExternalFileReference( PathType pathType ) |
Parameters
- pathType
- Type: Autodesk.Revit.DB..::..PathType
Remarks
- PathType.Server is only valid for ExternalFileReferences of type ExternalFileReferenceType.RevitLink
- PathType.Content is only valid for ExternalFileReferences of type ExternalFileReferenceType.KeynoteTable, ExternalFileReferenceType.AssemblyCodeTable and ExternalFileReferenceType.Decal
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |