List all shape parameters used by all the existing RebarShapes in the specified document.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static IList<ElementId> GetAllRebarShapeParameters( Document doc ) |
Visual Basic |
---|
Public Shared Function GetAllRebarShapeParameters ( _ doc As Document _ ) As IList(Of ElementId) |
Visual C++ |
---|
public: static IList<ElementId^>^ GetAllRebarShapeParameters( Document^ doc ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
The document.
Return Value
ElementIds corresponding to the external parameters.
Remarks
This method replaces RebarShape.GetAllRebarShapeParameters() from prior releases.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |