RebarShapeParametersGetAllRebarShapeParameters Method |
List all shape parameters used by all the existing RebarShapes in the specified document.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<ElementId> GetAllRebarShapeParameters(
Document doc
)
Public Shared Function GetAllRebarShapeParameters (
doc As Document
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetAllRebarShapeParameters(
Document^ doc
)
static member GetAllRebarShapeParameters :
doc : Document -> IList<ElementId>
Parameters
- doc Document
-
The document.
Return Value
IListElementId
ElementIds corresponding to the external parameters.
Exceptions
Remarks
This method replaces RebarShape.GetAllRebarShapeParameters() from prior releases.
See Also