File path of the image for the rendering background.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public string FilePath { get; set; } |
Visual Basic |
---|
Public Property FilePath As String Get Set |
Visual C++ |
---|
public: property String^ FilePath { String^ get (); void set (String^ value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The file specified by path is not an image file. A valid image file should be in one of the following formats: bmp, jpg, jpeg, png, tif. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | When setting this property: The file specified by path doesn't exist. |