Validates that the element is eligible for a solid-solid cut.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static bool IsAllowedForSolidCut( Element element ) |
Visual Basic |
---|
Public Shared Function IsAllowedForSolidCut ( _ element As Element _ ) As Boolean |
Visual C++ |
---|
public: static bool IsAllowedForSolidCut( Element^ element ) |
Parameters
- element
- Type: Autodesk.Revit.DB..::..Element
The solid to be cut or the cutting solid.
Return Value
True if the input element can participate in a solid-solid cut. False otherwise.
Remarks
The element must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |