Identifies whether the family contains parametric relations
between some of its elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public bool IsParametric { get; } |
Visual Basic |
---|
Public ReadOnly Property IsParametric As Boolean Get |
Visual C++ |
---|
public: property bool IsParametric { bool get (); } |
Remarks
A family is parametric if it contains parameter-driven relations between its elements, such as labeled dimensions or locked tangential joins.
Parametric families containing large sketches may cause performance problems. Caution is therefore advised before adding any constraints to a yet non-parametric family that already contains large sketches. See [!:DoesContainLargeSketches()].