Gets all RebarConstrainedHandles of this bar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public IList<RebarConstrainedHandle> GetAllHandles() |
Visual Basic |
---|
Public Function GetAllHandles As IList(Of RebarConstrainedHandle) |
Visual C++ |
---|
public: IList<RebarConstrainedHandle^>^ GetAllHandles() |
Return Value
All RebarConstrainedHandle objects will be returned, regardless of whether there are constraints associated to them.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | The RebarConstraintsManager does not manage a valid Rebar element. |