Remove a waypoint.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020.2
Syntax
C# |
---|
public void RemoveWaypoint( int index ) |
Visual Basic |
---|
Public Sub RemoveWaypoint ( _ index As Integer _ ) |
Visual C++ |
---|
public: void RemoveWaypoint( int index ) |
Parameters
- index
- Type: System..::..Int32
The index of the waypoint to remove.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Index refers to a non-existent waypoint. -or- This functionality is not available in Revit LT. -or- Cannot perform this operation for a path of travel in a group. |