Changes the service of the selection of fabrication parts.
Namespace: Autodesk.Revit.DB.FabricationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018.2
Syntax
C# |
---|
public FabricationNetworkChangeServiceResult ChangeService( ISet<ElementId> selection, int serviceId, int groupId ) |
Visual Basic |
---|
Public Function ChangeService ( _ selection As ISet(Of ElementId), _ serviceId As Integer, _ groupId As Integer _ ) As FabricationNetworkChangeServiceResult |
Visual C++ |
---|
public: FabricationNetworkChangeServiceResult ChangeService( ISet<ElementId^>^ selection, int serviceId, int groupId ) |
Parameters
- selection
- Type: System.Collections.Generic..::..ISet<(Of <(<'ElementId>)>)>
The set of element identifiers of fabrication parts to change the service for.
- serviceId
- Type: System..::..Int32
The identifier of the fabrication service.
- groupId
- Type: System..::..Int32
The identifier of the fabrication group.
Remarks
After this method has been invoked, call:
- GetStraightsThatWereNotChanged()()()() to get a set of fabrication part straight element identifiers that were not changed.
- [!:GetElementsThatHadFailures] to get a set of fabrication part element identifiers that had failures.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The selection contains invalid elements to change. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | No fabrication configuration is loaded. |