Retrieves analytical model projection information for Z direction.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public StickElementProjectionZ GetProjectionZ( AnalyticalElementSelector selector ) |
Visual Basic |
---|
Public Function GetProjectionZ ( _ selector As AnalyticalElementSelector _ ) As StickElementProjectionZ |
Visual C++ |
---|
public: StickElementProjectionZ GetProjectionZ( AnalyticalElementSelector selector ) |
Parameters
- selector
- Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
Return Value
Indicates if the projection is a preset value, or refers to a Plane.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |