Sets the analytical model projection to a preset value.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public void SetProjection( AnalyticalElementSelector selector, StickElementProjectionY projectionY, ElementId planeIdZ ) |
Visual Basic |
---|
Public Sub SetProjection ( _ selector As AnalyticalElementSelector, _ projectionY As StickElementProjectionY, _ planeIdZ As ElementId _ ) |
Visual C++ |
---|
public: void SetProjection( AnalyticalElementSelector selector, StickElementProjectionY projectionY, ElementId^ planeIdZ ) |
Parameters
- selector
- Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
- projectionY
- Type: Autodesk.Revit.DB.Structure..::..StickElementProjectionY
Preset value for Analytical Model Stick projection Y.
- planeIdZ
- Type: Autodesk.Revit.DB..::..ElementId
Plane on to which analytical model may be projected in Z direction. Plane identifies a Level, a Grid, or a Ref Plane.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |