Checks that the building envelope determination method falls within an appropriate range.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public static bool CheckBuildingEnvelope( gbXMLExportBuildingEnvelope determinationMethod ) |
Visual Basic |
---|
Public Shared Function CheckBuildingEnvelope ( _ determinationMethod As gbXMLExportBuildingEnvelope _ ) As Boolean |
Visual C++ |
---|
public: static bool CheckBuildingEnvelope( gbXMLExportBuildingEnvelope determinationMethod ) |
Parameters
- determinationMethod
- Type: Autodesk.Revit.DB.Analysis..::..gbXMLExportBuildingEnvelope
The building envelope determination method to be checked.
Return Value
True if the building envelope determination method falls within an appropriate range, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |