Indicates whether executions of the service requires serialization in documents or not.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public bool IsSerializable { get; } |
Visual Basic |
---|
Public ReadOnly Property IsSerializable As Boolean Get |
Visual C++ |
---|
public: property bool IsSerializable { bool get (); } |
Remarks
When a serializable service is executed in a document, a record about the executed
server (or servers) is stored in the document's history. This allows active servers
to be synchronized next time a saved document is opened in Revit.
Executions of a serializable service in a document must happen inside a transaction.