ExternalServiceIsSerializable Property |
Indicates whether executions of the service requires serialization in documents or not.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsSerializable { get; }
Public ReadOnly Property IsSerializable As Boolean
Get
public:
property bool IsSerializable {
bool get ();
}
member IsSerializable : bool with get
Property Value
Boolean
Remarks
When a serializable service is executed in a document, a record about the executed
server (or servers) is stored in the document's history. This allows active servers
to be synchronized next time a saved document is opened in Revit.
Executions of a serializable service in a document must happen inside a transaction.
See Also