A value that controls light and material accuracy mode.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public LightAndMaterialAccuracyMode LightAndMaterialAccuracyMode { get; set; } |
Visual Basic |
---|
Public Property LightAndMaterialAccuracyMode As LightAndMaterialAccuracyMode Get Set |
Visual C++ |
---|
public: property LightAndMaterialAccuracyMode LightAndMaterialAccuracyMode { LightAndMaterialAccuracyMode get (); void set (LightAndMaterialAccuracyMode value); } |
Remarks
The method of the renderer engine dealing with materials and shadows.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom. |