An enumerated type containing possible Light and Material Accuracy modes for Raytracer render.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public enum LightAndMaterialAccuracyMode |
Visual Basic |
---|
Public Enumeration LightAndMaterialAccuracyMode |
Visual C++ |
---|
public enum class LightAndMaterialAccuracyMode |
Members
Member name | Description |
---|---|
Simplified | Rough and semi-rough materials are approximated. Consequently, materials may look more shinier than expected. Lighting is approximated so shadows will lack in details. |
Advanced | Soft shadows and soft reflections from semi-rough materials will be rendered with a high quality level. This is the standard setting that you typically want to rely on for final high quality renderings. |