Creates a new arc length dimension object using the specified dimension type.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Dimension NewArcLengthDimension( View view, Arc arc, Reference arcRef, Reference firstRef, Reference secondRef, DimensionType dimensionType ) |
Visual Basic |
---|
Public Function NewArcLengthDimension ( _ view As View, _ arc As Arc, _ arcRef As Reference, _ firstRef As Reference, _ secondRef As Reference, _ dimensionType As DimensionType _ ) As Dimension |
Visual C++ |
---|
public: Dimension^ NewArcLengthDimension( View^ view, Arc^ arc, Reference^ arcRef, Reference^ firstRef, Reference^ secondRef, DimensionType^ dimensionType ) |
Parameters
- view
- Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
- arc
- Type: Autodesk.Revit.DB..::..Arc
The extension arc of the dimension.
- arcRef
- Type: Autodesk.Revit.DB..::..Reference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
- firstRef
- Type: Autodesk.Revit.DB..::..Reference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
- secondRef
- Type: Autodesk.Revit.DB..::..Reference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
- dimensionType
- Type: Autodesk.Revit.DB..::..DimensionType
The dimension style to be used for the dimension.
Return Value
If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument arcRef/ref1/ref2/dimensionType is invalid. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed. |