Inserts a VertexStreamPositionColored into the stream and associated buffer.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2017

Syntax

C#
public void AddVertex(
	VertexPositionColored vertex
)
Visual Basic
Public Sub AddVertex ( _
	vertex As VertexPositionColored _
)
Visual C++
public:
void AddVertex(
	VertexPositionColored^ vertex
)

Parameters

vertex
Type: Autodesk.Revit.DB.DirectContext3D..::..VertexPositionColored
The vertex to be inserted.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space.

See Also