Assigns scan override settings to a particular scan within a PointCloudInstance element.
Namespace: Autodesk.Revit.DB.PointCloudsAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public void SetPointCloudScanOverrideSettings( ElementId elementId, PointCloudOverrideSettings newSettings, string scanTag, Document doc ) |
Visual Basic |
---|
Public Sub SetPointCloudScanOverrideSettings ( _ elementId As ElementId, _ newSettings As PointCloudOverrideSettings, _ scanTag As String, _ doc As Document _ ) |
Visual C++ |
---|
public: void SetPointCloudScanOverrideSettings( ElementId^ elementId, PointCloudOverrideSettings^ newSettings, String^ scanTag, Document^ doc ) |
Parameters
- elementId
- Type: Autodesk.Revit.DB..::..ElementId
Id of the element to be overridden.
- newSettings
- Type: Autodesk.Revit.DB.PointClouds..::..PointCloudOverrideSettings
Override settings to be assigned.
- scanTag
- Type: System..::..String
The tag identifying the particular scan within the PointCloudInstance element. Tags can be obtained from PointCloudInstance via method getScans.
- doc
- Type: Autodesk.Revit.DB..::..Document
Document containing the element to be overridden.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when supplied scanTag is not empty while doc is NULL |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The override settings are not valid. |