PointCloudOverridesSetPointCloudScanOverrideSettings(ElementId, PointCloudOverrideSettings, String, Document) Method |
Assigns scan override settings to a particular scan within a PointCloudInstance element.
Namespace: Autodesk.Revit.DB.PointCloudsAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetPointCloudScanOverrideSettings(
ElementId elementId,
PointCloudOverrideSettings newSettings,
string scanTag,
Document doc
)
Public Sub SetPointCloudScanOverrideSettings (
elementId As ElementId,
newSettings As PointCloudOverrideSettings,
scanTag As String,
doc As Document
)
public:
void SetPointCloudScanOverrideSettings(
ElementId^ elementId,
PointCloudOverrideSettings^ newSettings,
String^ scanTag,
Document^ doc
)
member SetPointCloudScanOverrideSettings :
elementId : ElementId *
newSettings : PointCloudOverrideSettings *
scanTag : string *
doc : Document -> unit
Parameters
- elementId ElementId
-
Id of the element to be overridden.
- newSettings PointCloudOverrideSettings
-
Override settings to be assigned.
- scanTag String
-
The tag identifying the particular scan within the PointCloudInstance element.
Tags can be obtained from PointCloudInstance via method getScans.
- doc Document
-
Document containing the element to be overridden.
Exceptions
See Also